涨停后回调到5日线的选股公式,谢谢!

2024-06-25 08:57

1. 涨停后回调到5日线的选股公式,谢谢!

涨停:=c=(ROUND(ref(c,1)*110))/100;
5日内涨停:=ref(涨停,1) or ref(涨停,2) or ref(涨停,3) or ref(涨停,4) ;
回调:=(l=llvbars(l,5) and c<1.02*l);
ma5:=ma(c,5);
回td5rx:=c>0.98*ma5 and c<1.02*ma5 ;
条件:5日内涨停 and 回调 and 回td5rx;
 
以上公式第二句在飞狐中没有通过,错误提示是缺少分号;没有研究明白,改为以下语句飞狐测试通过。
涨停:(c=(ROUND(ref(c,1)*110))/100);
回调:=(l=llvbars(l,5)) and (c<1.02*l);
ma5:=ma(c,5);
回td5rx:=(c>0.98*ma5 and c<1.02*ma5);
条件:(((ref(涨停,1) or ref(涨停,2)) or ref(涨停,3)) or ref(涨停,4)) and 回调 and 回td5rx;

涨停后回调到5日线的选股公式,谢谢!

2. 股票跳空低开,收盘为阴线。成交量是前一日的两倍的编辑选股公式?谢谢

股票跳空低开,收盘为阴线。成交量是前一日的两倍的编辑选股公式A1:=BARSLAST(ref(cross("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=ref(c,A1+1)>c and ref("macd.diff"(12,26,9),A1+1)0,5),0,0.75,3,0),COLOR00FF00;
DRAWTEXT(FILTER(B1>0,5),0.57,'MACD底背离'),COLOR00FF00;
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)0,5),0,1,3,0),COLORYELLOW;
DRAWTEXT(FILTER(B2>0,5),0.80,'KDJ底背离'),COLORYELLOW;
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)0,5),0,0.5,3,0),COLORFFCC66;
DRAWTEXT(FILTER(B3>0,5),0.25,'RSI底背离'),COLORFFCC66;
DRAWTEXT(FILTER(D1>0,5),1.47,'MACD顶背离'),COLOR0066FF;
C2:=BARSLAST(ref(cross("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=ref(c,C2+1)"kdj.k"(9,3,3) and cross("kdj.d"(9,3,3),"kdj.k"(9,3,3));
KDJ顶背离:STICKLINE(FILTER(D2>0,5),2,1,3,0),COLORRED;
DRAWTEXT(FILTER(D2>0,5),1.2,'KDJ顶背离'),COLORRED;
C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=ref(c,C3+1)"RSI.RSI1"(6,12,24) and cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
RSI顶背离:STICKLINE(FILTER(D3>0,5),2,1.5,3,0),COLORFF00FF;
DRAWTEXT(FILTER(D3>0,5),1.75,'RSI顶背离'),COLORFF00FF;

3. 涨停板后20天内5天线和10天线二次死叉的选股公式?

可以编写这样的选股公式。
涨停后20天内,发生两次5天线死叉10天线效果如下图
图中黄色圈位置为两次死叉。
幅图中白色尖为第二次死叉并且当日离涨停小于20天这是选股信号条件成立位置。
。



涨停板后20天内5天线和10天线二次死叉的选股公式?